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Safety and Preparation For Use

WARNING!

Al

Caution

A

Dangerous voltages, capable of causing injury or death, are
present in this instrument. Use extreme caution whenever the
instrument cover is removed. Do not remove the cover while
the unit is plugged into a live outlet.

Thisinstrument may be damaged if operated with the LINE VOLTAGE SELECTOR set
for the wrong AC line voltage or if the wrong fuse isinstalled.

Line Voltage Selection

The SR785 operates from a 100V, 120V, 220V, or 240V nominal AC power source
having aline frequency of 50 or 60 Hz. Before connecting the power cord to a power
source, verify that the LINE VOLTAGE SELECTOR card, located in the rear panel fuse
holder, is set so that the correct AC input voltage value is visible.

Conversion to other AC input voltages requires a change in the fuse holder voltage card
position and fuse value. Disconnect the power cord, open the fuse holder cover door and
rotate the fuse-pull lever to remove the fuse. Remove the small printed circuit board and
select the operating voltage by orienting the printed circuit board so that the desired
voltage is visible when pushed firmly into its slot. Rotate the fuse-pull lever back into its
normal position and insert the correct fuse into the fuse holder.

Line Fuse
Verify that the correct line fuse is installed before connecting the line cord. For
100V/120V, use a1.5 Amp fuse. For 220V/240V, use a 3/4 Amp fuse.
Line Cord
The SR785 has a detachable, three-wire power cord for connection to the power source
and to a protective ground. The exposed metal parts of the instrument are connected to
the outlet ground to protect against electrical shock. Always use an outlet which hasa
properly connected protective ground.
Service
Do not attempt to service or adjust this instrument unless another person, capable of
V4 providing first aid or resuscitation, is present.
Do not install substitute parts or perform any unauthorized modifications to this
instrument. Contact the factory for instructions on how to return the instrument for
authorized service and adjustment.
Fan
The fansin the SR785 are required to maintain proper operation. Do not block the vents
in the chassis or the unit may not operate properly.
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Chapter 1

Performance Tests

The performance tests described in this section are designed to verify with a high degree of confidence

that the unit is performing within the specifications.

The results of each test should be recorded on the test sheet at the end of this section.

In This Chapter

Getting Ready
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Necessary Equipment
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Getting Ready

[Hardkeys]

The keypad consists of four groups of hardkeys (keys with printed labels).
Hardkeys are referenced in braces like [Active Display] or [Input].

The ENTRY keys are used to enter numeric parameters which have been highlighted by
a soft key. The MENU keys select amenu of soft keys. Pressing a menu key will change
the menu boxes which are displayed next to the soft keys. Each menu presents a group of
similar or related parameters and functions. The CONTROL keys start and stop data
acquisition, toggle the active display and link parameters and functions. These keys are
not in amenu since they are used frequently and within any menu. The FUNCTION keys
perform common functions such as Auto Scale and Auto Range. These keys can be
accessed at any time.

<Softkeys>

Knob

Reset

The SR785 has a menu driven user interface. The Menu keys each display a menu of
softkeys. The softkeys are at the right of the video display and have different functions
depending upon the displayed menu.

Softkeys are referenced in brackets like <Span> or <Units>.

There are three types of softkeys - buttons, lists and numeric values. A button performs a
function, such as <Full Span>. A list presentsalist of choices or optionsin the entry
field (at the top of the screen). Use the knob to make a selection and press [Enter].
<Measurement> is an example of alist. A numeric value presents the current value in the
entry field and awaits numeric entry. Enter a new value with the entry keys and press
[Enter]. <Start Freg> is an example of a numeric value.

The knob normally moves the markers within the displays. If a parameter has been
highlighted by its softkey, the knob adjusts the parameter. List parameters are most
easily modified with the knob. Numeric parameters may also be adjusted with the knob.

Knob list selections are referenced in parenthesis like (Hanning).

Throughout this section, it will be necessary to reset the analyzer into a known default
state. To do this, press [System] to display the System menu and then press <Preset> and
[Enter] to confirm. The unit will perform power up tests and then assume the default
settings. Each test generally starts with areset.

Serial Number

If you need to contact Stanford Research Systems, please have the serial number of your
unit available. The serial number is printed on alabel affixed to the rear panel. The serial
number is also displayed on the screen when the unit is powered on.
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Firmware Revision
The firmware revision code is displayed on the screen when the unit is powered on.

Necessary Equipment
The following equipment is necessary to complete the performance tests. The suggested
equipment or its equivalent should be used.

Frequency Synthesizer

Freq Range 1Hzto1MHz
Freq Accuracy better than 5 ppm
Amplitude Accuracy 0.2dB from 1 Hz to 100 kHz
Harmonic Distortion <-65dBc
Spurious <-55dBc
Recommended SRS DS345

AC Calibrator
Freg Range 10 Hz to 100 kHz
Amplitude ImVtoloV
Accuracy 0.1%

External phase locking capability
Recommended Fluke 5200A

Feedthrough Terminations
Impedance 50Q

Warm Up
The analyzer should be turned on and allowed to warm up for at least an hour before any
tests are performed. The self test does not require any warm up period.

It is necessary to turn the unit off and on to reset it. Aslong as the unit is powered within
aminute, thiswill not affect the test results.

Auto Offset must be left enabled (On) in the [Input] <More> menu. Disabling Auto
Offset may invalidate the results of some tests.

The Test Record
Make a copy of the SR785 Performance Test Record at the end of this section. Fill in the
results of the tests on this record. This record will allow you to determine whether the
tests pass or fail and also preserve arecord of the tests.

If A Test Fails
If atest fails, you should check the settings and connections of any external equipment
and, if possible, verify its operation using aDV M, scope or some other piece of test
equipment.

After checking the setup, repeat the test from the beginning to make sure that the test was
performed correctly.
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If the test continues to fail, contact Stanford Research Systems for further instructions.
Make sure that you have the unit serial number and firmware revision code handy. Have
the test record on hand as well.
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1. Self Tests

The self tests check the analyzer hardware. These are functional tests and do not relate to the
specifications. These tests should be run before any of the performance tests.

Note that the Test menu offers more tests than are required here. Only those tests, which require no
additional equipment, are discussed in this section. The computer interface and disk drive tests are not
required but should be periodically checked. See the System menu for more information about those
tests.

Setup
No external setup isrequired for thistest.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.
During re-boot, the DSP memory and calibration tests should all be OK.
To review this power on screen, use [ System] <Show Version>.

2) Pressthe keysin the following sequence:

SR785 Dynamic Sgnal Analyzer
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[System]
<Diagnostics>
<Keypad Test>
Press all of the front panel keys until all of the boxes arefilled in.
Then press any key to exit this screen.

<Knob Test>
Rotate the knob to verify rotation and direction.
<Return>

<Memory >
<System RAM>
<Begin>
All of the system memory chips should Pass.
<Return>

<System ROM>
<Begin>
All of the system memory chips should Pass.
<Return>

<Video RAM>
<Begin>
All of the video memory chips should Pass.
<Return>

<Help ROM>
<Begin>
All of the memory chips should Pass.
<Return>

<Return>

3) This completes the functional hardware tests. Enter the results of thistest in the test record at the
end of this section.
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2. DC Offset

Thistest measures the DC offset of the input.

Setup
Connect a 50Q feedthrough termination to the Chl A and Ch2 A inputs. This shorts the inputs so the
analyzer's own DC offset will be measured.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Pressthe keysin the following sequence:

[Fred]
<Span>
[1] [] [6] select (kHz) [Enter]

[Marker]
<Marker>
Select (Link) [Enter]
Use the knob to move the markersto O Hz.

[Average]
<Averaging Type>
Select (Linear/Fixed Length) [Enter]
<# Avgs>
[1] [O] [Enter]
<Display Average>
Select (RMS) [Enter]

3) a) Press
[Input]
<Input Configuration>
<Chl Input Range>
<Channel>
Select (Both) [Enter]
<Chl Input Range>
[-] [3] [O] [Enter]
[Start/Reset]
Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

b) Record the marker Y values for both displays on the -30 dBV range.

c) Press
<Chl Input Range>
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[-] [5] [0] [Enter]

[Start/Reset]

Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

d) Record the marker Y values for both displays for the -50 dBV range.

4) This completes the DC measurement test. Enter the results of thistest in the test record at the end
of this section.
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3. Common Mode Rejection

This test measures the common mode rejection of the analyzer inputs.

Setup
We will use the frequency synthesizer to provide the signal.

Connect the frequency synthesizer output to both the Chl A and Chl B inputs of the analyzer. Use equal
length cables from A and B to aBNC TEE. Connect the cable from the synthesizer output to the TEE.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Set the frequency synthesizer to afrequency of 1 kHz and an amplitude of 500 mVrmes.

3) Setup the measurement. Press the keys in the following sequence:

[Freq]
<Span>
[1] [.] [6] Select (kHz) [Enter]
<Center Freq.>
[1] Select (kHZ) [Enter]

[Input]
<Input Config>
<Chl Input Range>
[-] [2] [Enter]

[Average]
<Averaging Type>
Select (Linear/Fixed Len) [Enter]
<# Avgs>
[1] [O] [Enter]
<Display Avg>
Select (RMS) [Enter]
Wait for the average to finish.

[Auto Scale A]
[Marker Max]
[Marker Ref]

[Input]
<Input Config>
<Chl Input Mode>
Select (A-B) [Enter]
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[Start/Reset]
Wait for the average to finish.

4) Record the marker Y reading. Thisisthe Chl CMRR (in dB) at 1 kHz.

5) Move the input cables from Chl A and B to Ch2 A and B.
Repeat the measurement for Ch2.
Press the keysin the following sequence:

[Active Display]
Make DisplayB the active display.

[Input]
<Channel>
Select (Ch2) [Enter]
<Ch2 Input Range>
[-] [2] [Enter]

[Start/Reset]
Wait for the average to finish.

[Auto Scale B]
[Marker Max]
[Marker Ref]

[Input]
<Input Config>
<Ch2 Input Mode>
Select (A-B) [Enter]

[Start/Reset]
Wait for the average to finish.

6) Record the marker Y reading. Thisisthe Ch2 CMRR (in dB) at 1 kHz.

7) This completes the CMRR measurement test. Enter the results of thistest in the test record at the
end of this section.
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4. Amplitude Accuracy and Flatness

This test measures the input amplitude accuracy and frequency response.

Setup
We will use the frequency synthesizer to provide an accurate frequency and the AC calibrator to provide
a sine wave with an exact amplitude.

Connect the output of the frequency synthesizer to the phase lock input of the calibrator. Connect the
output of the AC calibrator to the Chl A and Ch2 A inputs of the analyzer. Be sure to use the appropriate
terminations where required.

Set the Synthesi zer to: Set the AC Cadlibrator to:
Function Sine Frequency 1.0kHz
Freqguency  1.0kHz Amplitude 0.707 mVrms
Amplitude  0.5Vrms Voltage Off
Offset off or OV Phase Lock On
Sweep off Sense Internal

Modulation none

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Pressthe keysin the following sequence:

[Window]
<Window>
Select (Flattop) [Enter]

[Freq]
<Span>
[1] [.] [6] Select (kHz) [Enter]
<Center Freq.>
[1] Select (kHZ) [Enter]

[Input]
<Input Config>
<Channel>
Select (Both) [Enter]
<Ch1 Coupling>
Select (AC) [Enter]
[Average]
<Averaging Type>
Select (Linear/Fix Len) [Enter]
<# Avgs>
[1] [O] [Enter]
<Display Avg>
Select (RMS) [Enter]
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3) Amplitude accuracy is verified at 1.0 kHz and various input ranges. For each range setting in the
table below, perform steps 3a through 3d.

Input Range (pk) AC Calibrator Amplitude
-46 dBV 2.509 mVrms
-38 dBV 6.302 mVrms
-30dBV 15.830 mVrms
-14 dBV 99.881 mVrms
4 dBV 0.7934 Vrms
10dBV 1.5830 Vrms
22 dBV 6.3021 Vrms
34 dBV 25.089 Vrms

a) Set the AC calibrator to the amplitude shown in the table.

b) Press

[Input]

<Chl Input Range>

Enter the range from the table.

c) Press
[Start/Reset]

Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

[Link] [Marker Max]
d) Record the marker Y reading for both displays for each range.

4) Frequency responseis checked at frequencies above 1 kHz. The test frequencies are listed below.
The measurements are performed for two different input ranges.

Test Freguencies
24 kHz
48 kHz
72 kHz
96 kHz

a) Set the AC calibrator to 1.0 kHz and an amplitude of 99.881 mVrmes.
b) Set the frequency synthesizer to 1.0 kHz.

c) Press
[Frequency]
<Center Frequency.>
[1] Select (kHz) [Enter]
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[Input]
<Chl Input Range>
[-] [1] [4] [Enter]
[Start/Reset]
Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

[Link] [Marker Max]
TheY value of the markers should both read -17.0 dB (+ 0.15 dB).

d) Set the AC calibrator and frequency synthesizer to the frequency in the table.
€e) Press
[Frequency]
<Center Freq.>
Enter the signal frequency.

[Start/Reset]
Wait for the average to settle.

[Link] [Marker Max]

f) Record the marker Y reading for both displays. Repeat steps 4d and 4efor all of the
frequencies listed.

5) Now repeat the frequency response measurements at a different input range.
a) Set the AC calibrator to 1 kHz and an amplitude of 6.3021 Vrmes.

b) Set the frequency synthesizer to 1 kHz.

c) Press
[Freq]
<Center Freqg..>
[1] <kHz>
[Input]

<Chl Input Range>
[2] [2] [Enter]

[Start/Reset]

Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

[Link] [Marker Max]
TheY value of the marker should now read +19.0 dB (+0.15 dB).
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d) Repeat steps 4d through 4f above.

6) This completes the amplitude accuracy and frequency response test. Enter the results of this test
in the test record at the end of this section.
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5. Amplitude Linearity

Thistest measures the amplitude linearity. This tests how accurately the analyzer measures a signal
smaller than full scale.

Setup
We will use the frequency synthesizer to provide an accurate frequency and the AC calibrator to provide
a sine wave with an exact amplitude.

Connect the output of the frequency synthesizer to the phase lock input of the calibrator. Connect the
output of the AC calibrator to the Chl A and Ch2 A inputs of the analyzer. Be sure to use the appropriate
terminations where required.

Set the Synthesizer to: Set the AC Cadlibrator to:
Function Sine Frequency 1.0kHz
Freqguency  1.0kHz Amplitude 6.3021 Vrms
Amplitude  0.5Vrms Voltage Off
Offset off or OV Phase Lock On
Sweep off Sense Internal

Modulation none

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Pressthe keysin the following sequence:

[Window]
<Window>
Select (Flattop) [Enter]

[Freq]
<Span>
[1] [.] [6] Select (kHz) [Enter]
<Center Freq.>
[1] Select (kHZ) [Enter]

[Input]
<Input Config>
<Channel>
Select (Both) [Enter]
<Ch1 Coupling>
Select (AC) [Enter]
<Chl Input Range>
[2] [2] [Enter]
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[Average]
<Averaging Type>
Select (Linear/Fix Len) [Enter]
<# Avgs>
[1] [O] [Enter]
<Display Aveg>
Select (RMS) [Enter]

[Start/Reset]

Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

[Link] [Marker Max]
3) For each of the amplitudes listed below, perform steps 3a through 3c.

AC Calibrator Amplitudes
6.3021 Vrms
1.1207 Vrms
141.09 mVrms
22.361 mVrms
3.544 mVrms

a) Set the AC calibrator to the amplitude in the table.
b) Press [Start/Reset] and wait for the average to finish.
¢) Record the marker Y reading for both displays.

4) This completes the amplitude linearity test. Enter the results of thistest in the test record at the
end of this section.
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6. Anti-alias Filter Attenuation

This test measures the attenuation of the anti-alias filters. This tests how well the analyzer rejects

frequencies outside the 102.4 kHz frequency range.

Setup

We will use the frequency synthesizer to provide the signal.

Connect the output of the frequency synthesizer to the Chl A and Ch2 A inputs of the analyzer. Be sure

to use the appropriate terminations where required.

Procedure

1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Set the frequency synthesizer to afrequency of 160.144 kHz and an amplitude of 500 mVrms.

3) Pressthe keysin the following sequence:

[Freq]
<Span>
[8] [O] [O] Select (Hz) [Enter]
<Center Freq.>
[1] [O] [2] Select (kHZ) [Enter]

[Input]
<Input Config>
<Channel>
Select (Both) [Enter]
<Chl AA Filter>
Select (Off) [Enter]

[Average]
<Averaging Type>
Select (Linear/Fix Len) [Enter]
<# Avgs>
[1] [O] [Enter]
<Display Avg>
Select On [Enter]

[Start/Reset]

Wait for the average to finish.
[Auto Scale A]
[Auto Scale B]

SR785 Dynamic Sgnal Analyzer



1-20 Performance Tests

[Link] [Marker Max]

[Link] [Marker Ref]
This references the un-filtered out of band signal at 160.144 kHz aliased to
102.0 kHz.

4) Measure the anti-alias filter attenuation. Press
[Input]
<Input Config>
<Channel>
Select (Both) [Enter]
<Chl AA Filter>
Select (On) [Enter]
[Start/Reset]
Wait for the average to finish.

Record the marker Y readings for both displays.

5) This completes the anti-alias filter attenuation test. Enter the results of thistest in the test record
at the end of this section.
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/. Frequency Accuracy

This test measures the frequency accuracy of the analyzer. This tests the accuracy of the fundamental
crystal timebase inside the unit.

Setup
We will use the frequency synthesizer to provide the signal.

Connect the output of the frequency synthesizer to the Chl A input of the analyzer. Be sure to use the

appropriate terminations where required.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Set the frequency synthesizer to a frequency of 96.000 kHz and an amplitude of 500 mVrms.

3) Pressthe keysin the following sequence:

[Freq]
<Span>
[2] [O] [O] Select (Hz) [Enter]
<Center Freq.>
[9] [6] Select (kHZ) [Enter]
[Start/Reset]

[Auto Scale A]
[Marker Max]

4) Wait for the spectrum to settle (at least 5 seconds), then record the marker frequency reading for
DisplayA.

5) This completes the frequency accuracy test. Enter the results of thistest in the test record at the
end of this section.
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8. Phase Accuracy

This test measures the phase accuracy of the analyzer. Thistest measures the phase of asignal relative to
the trigger.

Setup
We will use the frequency synthesizer to provide the signal.

Connect the output of the frequency synthesizer to the Trigger, Chl A and Ch2 A inputs of the analyzer.
Be sure to use the appropriate terminations where required.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Set the frequency synthesizer to a frequency of 10.240 kHz and an amplitude of 500 mVrms.

3) Pressthe keysin the following sequence:

[Input]
<Input Config>

<Channel>
Select (Both) [Enter]

<Chl Input Range>
[][2] <dBV>

<Ch1 Coupling>
Select (AC) [Enter]

[Trigger]
<Trigger Source>
Select (Chl) [Enter]
[Auto Scale A]
[Auto Scale B]

[Marker]
<Marker>
Select (Link) [Enter]

[Marker Max]

[Display Setup]
<View>
Select (Phase) [Enter]

[Active Display]
Make DisplayB the active display.
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[Display Setup]
<View>
Select (Phase) [Enter]

[Auto Scale A]
[Auto Scale B]

[Average]

<# Avgs>
[1] [O] [Enter]

<Display Avg>
Select (Vector) [Enter]

<Averaging Type>
Select (Linear) [Enter]

4) Record the marker Y readings for both displays. (Make sure that the marker frequency is
10.24 kHz)

5) This completes the phase accuracy test. Enter the results of this test in the test record at the end
of this section.
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[Average]
<# Avgs>
[2] [O] [Enter]
<Averaging Type>
Select (Linear/Fix Len) [Enter]
<Display Avg>
Select (RMS) [Enter]

[Marker]
<Width>
[Link] Select (Wide) [Enter]
<Seeks>
[Link] Select (Mean) [Enter]

[Start/Reset]
Wait for the average to finish.

[Link] [Marker Max]
3) Record the marker Y readings for both displays.

4) Press

[Freq]
<Start Freq.>
[5] [1] [.] [2] Select (kHz) [Enter]

[Start/Reset]
Wait for the average to finish.

[Link] [Marker Max]
5) Record the marker Y readings for both displays.

6) Press
[Display Optiong]|

[Display Setup]
<Units>
<Pk. Units>
Select (pk) [Enter]
<PSD Units>
Select (Off) [Enter]

[Marker]
<Seeks>
Select (Max) [Enter]

7) For each of the spans listed below, perform steps 7a through 7c.
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Center Freguency Span
230 Hz 400 Hz
500 Hz 400 Hz
1kHz 1.6 kHz
5kHz 1.6 kHz
10 kHz 1.6 kHz
25 kHz 1.6 kHz
50 kHz 1.6 kHz
75 kHz 1.6 kHz
101 kHz 1.6 kHz
a) Press
[Freq]
<Span>
Enter the span from the table
<Center Freq.>
Enter the center frequency from the table
[Start/Reset]

b) Wait for the average to finish (20 averages).

[Link] [Marker Max]

¢) Record the marker Y readings for both displays.

8) This completes the noise and spurious signal test. Enter the results of thistest in the test record at

the end of this section.
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10. Sine Source

This test measures the source sine output.

Setup
Connect the Source output to the Chl A input.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.

2) Pressthe keysin the following sequence:
[Source]
<Amplitude 1>
[1] [O] [O] [O] [Enter]
[On]
[Auto Range Ch1l] and wait until the range stops changing.
[Auto Scale A]
[Marker Max]
3) Record the marker Y reading for DisplayA.

4) Press
<Amplitude 1>
[1] [O] [O] [Enter]

5) Record the marker Y reading for DisplayA.
6) Press
<Amplitude 1>
[1] [O] [Enter]
7) Record the marker Y reading for DisplayA.
8) Press

<Amplitude 1>
[1] [O] [O] [O] [Enter]
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9) For each of the frequencies below, perform steps 9a and 9b.

Frequency
20.48 kHz

40.96 kHz
61.44 kHz
81.92 kHz
99.072 kHz

a) Press
<Freguency 1>
Enter the frequency from the table.
[Marker Max]
b) Record the marker Y reading for DisplayA.

8) This completes the source sine test. Enter the results of thistest in the test record.
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11. Harmonic Distortion

This test measures the harmonic distortion of the analyzer source and inputs.

Setup
Connect the source output to the Chl A and Ch2 A inputs of the analyzer.

Procedure
1) Reset the unit by pressing [System] <Preset> and then [Enter] to confirm.
This sets the source to sine output at 10.24 kHz and 500 mV pk amplitude.

2) Pressthe keysin the following sequence:
[Source]
<On>
[Input]
<Input Config>
<Channel>
Select (Both) [Enter]
<Chl Input Range>
[-] [4] [Enter]
[Auto Scale A]
[Auto Scale B]

[Average]
<# Avgs>
[2] [5] [Enter]
<Display Average>
Select (Vector) [Enter]
[Marker]
<Mode>
[Link] Select (Harmonic) [Enter]
<# Harmonics>
[Link] [5] [Enter]

[Link] [Marker Max]
3) Record the THD reading for DisplayA (from the THD menu box).
4) Press
[Active Display]
Make DisplayB the active display.
5) Record the THD reading for DisplayB (from the THD menu box).

6) This completes the harmonic distortion test. Enter the results of thistest in the test record at the
end of this section.
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SR785 Performance Test Record Pegelof 3
Serial Number Tested By
Firmware Revision Date
Equipment Used
1. Self Tests
Test Pass Fail
Power On Test _ _
Keypad - -
Knob _ _
System RAM _ _
System ROM _ _
Video RAM _ _
Help ROM _ _
2. DC Offset
Input Range  DispA (Chl) DispB (Ch2)  Upper Limit
-30 dBV < -80dBV
-50 dBV < -80dBV
3. Common Mode Rejection
Input Range Frequency  DispA (Chl) DispB (Ch2) Upper Limit
-2 dBV 1.0 kHz <-90dB
4. Amplitude Accuracy and Flatness
Input Range  Calibrator Ampl. Lower Limit DispA (Chl) DispB (Ch2) Upper Limit
-46 dBV 2.509 mVrms -49.20 dBV -48.80 dBV
-38 dBV 6.302 mVrms -41.20 dBV -40.80 dBV
-30 dBV 15.830 mVrms -33.20dBV -32.80 dBV
-14 dBV 99.881 mVrms -17.20 dBV -16.80 dBV
4 dBV 0.7934 Vrms 0.80 dBV 1.20 dBV
10dBV 1.5830 Vrms 6.80 dBV 7.20 dBV
22 dBV 6.3021 Vrms 18.80 dBV 19.20 dBV
34 dBV 25.089 Vrms 30.80 dBV 31.20dBV
Flatnessrelativeto 1 kHz
Input Range Freguency Lower Limit DispA (Chl) DispB (Ch2) Upper Limit
-14 dBV 24 kHz -17.20 dBV -16.80 dBV
-14 dBV 48 kHz -17.20 dBV -16.80 dBV
-14 dBV 76 kHz -17.20 dBV -16.80 dBV
-14 dBV 99 kHz -17.20 dBV -16.80 dBV
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SR785 Performance Test Record Page 2 of 3
4. Amplitude Accuracy and Flatness (Continued)
Flatnessrelativeto 1 kHz
Input Range Freguency Lower Limit DispA (Chl) DispB (Ch2) Upper Limit
22 dBV 24 kHz 18.80 dBV 19.20 dBV
22 dBV 48 kHz 18.80 dBV 19.20 dBV
22 dBV 72 kHz 18.80 dBV 19.20 dBV
22 dBV 96 kHz 18.80 dBV 19.20 dBV
5. Amplitude Linearity
Input Range  Calibrator Ampl. Lower Limit DispA (Chl) DispB (Ch2) Upper Limit
22 dBV 6.3021 Vrms 18.80 dBV 19.20 dBV
1.1207 Vrms 3.80dBV 4.20 dBV
141.09 mVrms -14.20 dBV -13.80 dBV
22.361 mVrms -30.20 dBV -29.80 dBV
3.544 mVrms -46.20 dBV -45.80 dBV
6. Anti-Alias Filter Attenuation
Input Frequency  DispA (Chl) DispB (Ch2) Upper Limit
160.144 kHz <-90dB
7. Frequency Accuracy
Input Frequency Lower Limit DispA Upper Limit
96.000 kHz  95.9976 kHz 96.0024 kHz
8. Phase Accuracy
Frequency Trigger Source Lower Limit DispA (Chl) DispB (Ch2) Upper Limit
10.24 kHz Chi -93.0 deg -87.0 deg
9. Noise and Spurious Signals
Noise floor Start Frequency Span DispA (Chl) DispB (Ch2) Upper Limit
512 Hz 51.2 kHz -160 dBVrms/VHz
51.2 kHz 51.2 kHz -160 dBVrms/VHz
Spurioussignals  Center Frequency Span DispA (Chl) DispB (Ch2) Upper Limit
230 Hz 400 Hz -135 dBVpk
500 Hz 400 Hz -140 dBV pk
1kHz 1.6 kHz -140 dBV pk
5kHz 1.6 kHz -140 dBV pk
10 kHz 1.6 kHz -140 dBV pk
25 kHz 1.6 kHz -140 dBV pk
50 kHz 1.6 kHz -140 dBV pk
75 kHz 1.6 kHz -140 dBV pk
101 kHz 1.6 kHz -140 dBV pk
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SR785 Performance Test Record

Page 3 of 3

10. Sine Source

Amplitude
Freguency Level Lower Limit DispA Upper Limit
1kHz 1000 mV -0.3dBV 0.3dBV
1kHz 100 mV -20.3dBV -19.7 dBV
1kHz 100 mv -40.3 dBV -39.7 dBV
Amplitude Flatness
Freguency Level Lower Limit DispA Upper Limit
20.48 kHz 1000 mV -0.3dBV 0.3dBV
40.96 kHz 1000 mV -0.3dBV 0.3dBV
61.44 kHz 1000 mV -0.3dBV 0.3dBV
81.92 kHz 1000 mV -0.3dBV 0.3dBV
99.072 kHz 1000 mV -0.3dBV 0.3dBV
11. Harmonic Distortion
Fundamenta  DispA THD DispB THD  Upper Limit
10.24 kHz <-80dB
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the way to the front panel BNC connectors. The analyzer backplane connects to the
system backplane via two short cables at the center of the chassis just behind the CRT.

Figure 7-2 Analyzer Components

Chassis Top View

DSP Board

Chl Anaog
Input Board

Ch2 Anaog
Input Board

Analyzer
Backplane

Front

Both the system and the analyzer backplanes are passive and contain no active circuitry.
They only provide power distribution, signal routing between the various boards and to
external ports or devices.

Schematic Diagram Locations
Schematic diagrams are located in Chapter 5.

Board/Assembly Schematic # s (see Chapter 5)
CPU Board MCPU-1 through MCPU-9
Video/IO Board MVID-10 through MVID-14
Power Supply MPWR-1 through MPWR-2
System Backplane MBKPL-20 through MBKPL-23
Disk Card MBKPL-24

Keypad Board MKEY-1

DSP Board D785-1 through D785-11

Analog Input Boards  A780-1 through A780-7
Analyzer Backplane  M780-1 through M780-4
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CPU Board

This section covers schematics MCPU-1 through MCPU-9 in Chapter 5.

The CPU board contains the main microprocessor system. CPU memory, front panel and
printer interfaces are on this board. Two off-board data buses are also driven from this
board. The I/O Expansion data bus connects the CPU board with the Video/IO and Aux
dots on the System backplane. The External data bus connects to the DSP Board viathe
Analyzer backplane.

Microprocessor System
The microprocessor, U101, isan 80C186XL (or 80C186EA) microcontroller which
integrates afast 16 bit processor, counter-timers, interrupt controller, DMA controller,
and 1/0O decoding into a single component.

The 80C186 is clocked at 40.00 MHz by crystal oscillator U103. The external clock
period is 2 oscillator cycles or 20.0 MHz. The data and lower 16 bits of address are
multiplexed on processor lines ADO-AD15. U201, U202, U203 latch the address AO-A19
at the beginning of each memory or 1/0 cycle. U204 and U205 are bi-directional data bus
drivers which are active during the data read/write portion of each memory or 1/O cycle.
U201-U205 provide the on-board System bus.

Memory Map
The 80C186 can address 1 Mbyte of memory and 64k of 1/O space. The memory is
mapped into 5 blocks. Each block has 2 sockets, one for the low byte and one for the
high byte of data.

U301-U304 are 128 kbyte EPROM S mapped from 80000H to FFFFFH. EPROM S U305
and U306 are mapped from 50000H to 7FFFFH for atotal of 704 kbytes of program
ROM.

U401-U404 are 128 kbyte CMOS static RAMs mapped from 00000H to 4FFFFH
(320 kbytes). U401 and U402 (256 kbytes) are battery backed up.

I/0 Map
U209 and U210 are the data bus drivers for the off-board I/O Expansion bus. U206 and
U207 are the data bus drivers for the off-board External (DSP) bus. U208 is the address
driver for the External bus.

U213 isaPAL which enables the correct bus drivers depending upon the 1/0O address
space being accessed. All memory accesses and on-board 1/0 use the System bus.

The 80C186 generates 7 peripheral chip select strobes, each covering 128 byte 1/0
addresses. -PCS0 enables on-board 1/0 peripherals (front panel, clock and printer port).
-PCSL1 enables the peripherals on the Video/lO board. -PCS2 enables the AUX
connectors on the System backplane. -PCS1 and -PCS2 enabl e the Expansion data bus. -
PC$4 and -PCS5 enable the External (DSP) bus. -PCS4 enables processor addressable
peripherals on the DSP board.
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U501 and U503 decode the on-board I/O locations enabled by -PCS0. These are the
knob, keypad and keyboard, the clock, the printer port and the system status port.

U508 is await state generator. Extra wait states are generated by all 1/0 accesses. These
extrawait states are canceled if the accessis to the External bus. The -Video_Rdy signal
also ends the wait generation. -Video_Rdy signals that the graphics processor (on the
Video/lIO board) has acknowledged an 10 cycle and is ready.

Interrupts generated by system peripherals (on both the CPU and Video/IO boards) are
combined in U505 into asingle prioritized interrupt. The highest priority pending
interrupt will be encoded on U505's outputs and read via the status port, U608. The
UART directly interrupts the processor since it can never be masked.

String ROM
U801 and U802 are 256 kbyte EPROM S containing the on-screen help information.
These memories are mapped into the upper 32k of 1/O space. One of the sixteen 32k
banksis selected by BA15..BA18 set in the system status port. This keeps ROM data
from using up program memory space.

Keypad Interface
The keypad is organized as 8 columns and 8 rows of switch closures. The conductive
rubber keys provide the switch closures. U607 strobes the columns and U606 detects the
switch closure. The diodes D601-D608 prevent one column from affecting another. All
of the outputs from U607 are set high and U606 is read periodically by the processor. As
long as O0OH isread, no key is pressed and the strobes are left on. When anon-zero value
isread, then the key strobes are activated individually in order to decode which key is
down.

Spin Knob
The knob is an optical encoder buffered by U612. Each transition of its quadrature
outputsis clocked into U610 or U611 and generates an interrupt at the output of US07B.
The processor keeps track of the knob's direction and speed.

Keyboard Interface
The PC keyboard interface uses U603 to convert serial data from the keyboard into a
parallel byte for the processor to read. The data format from the keyboard is aleading
start bit followed by 8 data bits. U603 is reset by a processor read. When akey is
pressed, the bits are shifted into U603. When the start bit appears at the QH output, 7 bits
of the data byte are in U603. U601 is the 9th bit of the shift register. When U601 clocks
in the start bit, U601 must have the 8 bits of the data. U601 then latches the serial datain
U601 and interrupts the processor.

Only keyboards which operate in the PC or 8088 mode will function with thisinterface.
Speaker

The speaker is driven by atimer on the 80C186. The timer outputs a square wave which
is enabled by U507A and drives the speaker through Q705.
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Clock/Calendar
U702 isan MC146818 real time clock chip which keeps track of time and date. The time
baseis a 32.768 kHz oscillator made by U706. Both U702 and U706 are battery backed

up.

Reset/Battery Switch
U701 isthe processor supervisor. Power on reset is detected by U701 and signaled to the

processor via-Pwr_Reset. In addition, the chip enables to the battery backed-up memory
U401 and U402 are protected by U701. Q701 provides normal 5V power to the battery
circuits when the power is on.

Printer Interface
The printer interface is anormal Centronics style parallel port. Output datais buffered by
U703, an LS octal latch. Output control bits are buffered by the open collector driver
U704, and input control bits are discriminated by U705A and U705B.

Expansion Connector
The 120 pin connector carries all of the necessary interconnections to the System
backplane. Both the Expansion and External buses are carried off-board viathis
connector. Power is aso delivered through this connector.
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Video/IO Board

This section covers schematics MV ID-10 through MVID-14 in Chapter 5.

The Video/IO board contains the display generation hardware, the GPIB and RS232
interfaces and the disk controller.

Video Graphics Interface
The video graphicsinterface is centered around U1003, an HD63484 graphics controller.
The HD63484 generates the video sync signals, controls the video memory, draws
graphic primitives such as lines, circles, polygons, etc. and performs many memory to
memory functions. The HD63484 relieves the 80C186 from having to calculate each
video image and greatly increases display speed.

Commands and data are sent from the 80C186 to the HD63484 using a DMA channel.
This alows the HD63484 to process commands without having to wait for the 80C186 to
send them.

U1006 and U1007 are 128 kbyte RAMs which make up the 256k video memory. Each
pixel is made up of 2 bits. The video screen is 800H by 600V and requires 120,000 bytes
of memory. The remaining memory is used to store patterns and fonts as well as a second
display screen. The data and address are multiplexed and U1004 and U1005 are the
address |atches.

Memory is accessed twice during each display cycle. The first access reads the 16 bits of
video datafor the current display cycle. The second access is used by the controller for
drawing purposes. During the drawing access, data at any address may be read or
written. This allows drawing to take place as fast as possible.

Dataisread 16 bits at atime. When datais required for the display, the even data bits are
latched into U1008 and the odd data bits are latched into U1009. U1008 and U1009 are
parallel to serial converters. The video datais shifted out at 19.59 MHz and synchronized
by U1013. U1014A synchronizes the Display Enable to disable the video data except
during active display times.

The display consists of two layers or planes. Data on the front plane appearsin front of
data on the rear plane. Each pixel requires two bits of information. The even bit is drawn
on the front plane and the odd bit is drawn on the rear plane. The even bit disables the
odd bit which putsit in front. U1012 handles the layering logic. The display planes make
it simple to draw agraph in front of agrid.

The two display planes each have their own display brightness. This givesthe display a
three dimensional appearance. Current sources Q1101 and Q1102 set the brightness for
the front and rear planes. U1101 is adual DAC which programs the two current sources.

Disk Controller
U1201 isaDP8473 disk controller which integrates all of the functions of the PC disk
interface into asingle IC. All motor controls, read and write signals, and data are
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